Jump to content


Photo

Installation problems (again)


  • Please log in to reply
2 replies to this topic

#1 Dany

Dany
  • Members
  • 127 posts

Posted 06 February 2016 - 02:27 PM

I have had such a bad experience of the IDE that i wanted to install SMS on the "host" (i run all development in VMs) to see if some of the troubles stem from running it in a VM. So i downloaded "Professional" from the site. Installed and registered.

 

Now; there's no "Check for Updates", there's no SmartUpdate.exe. And this is not 2.2 Beta 5. So i ran SmartUpdate in the program folder and that did not work at all because the places for binaries and RTL+ stuff. One is in Program Files (x86) and the other in Program Data (user/AppData) and that does not match with what i have in the VM and what SmartUpdate does.

 

Simply put - this messed up the structure completely.

 

I'm not going to ask what i missed because sifting through the site or the forum is a pain. Normally a paying user goes to downloads. No?



#2 Jørn E. Angeltveit

Jørn E. Angeltveit
  • Administrators
  • 297 posts
  • LocationNorway

Posted 06 February 2016 - 03:20 PM

When you run the current SmartUpdate, all files will be placed in the same folder.  (The same folder as SmartUpdate.exe itself, by default).

 

Thus, you can install the beta as an isolated environment wherever you want on your computer.  "Program files" is perhaps the only folder you should try avoid due to various Windows security rules.  

 

So...

 

To establish a new setup:

Create a new folder on your desktop or directly on C:\  (Eg: C:\Smart-Beta\)  and put SmartUpdate in this folder.  Then run this file and get all the files you need.

 

 

To cleanup the mess:

Run the uninstaller.

Check manually:

- "Program files" directory

- "Smart Mobile Projects" under "My documents"

- "Optimale Systemer AS" under "C:\ProgramData"



#3 Dany

Dany
  • Members
  • 127 posts

Posted 13 February 2016 - 01:32 PM

Thanks!

 

/D






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users