Jump to content

Search the Community

Showing results for tags 'error'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

There are no results to display.

Forums

  • Welcome to Smart Mobile Studio
    • News and Information
    • Pre-Sales Questions
    • Smart In the Media
    • Smart Contests
    • Meta
  • Smart Mobile Studio Discussion
    • General
    • IDE
    • RTL
    • Code
    • Client Server
    • Platform
    • Graphics
    • Deployment
    • Suggestion box
  • Smart Mobile Studio support
    • Support
    • Bug report
  • General Discussion
    • Pascal
    • Delphi
    • Javascript
    • HTML/HTML5
    • CSS
  • Resources
    • Website
    • Download Smart Mobile Studio

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Company name


Position

Found 5 results

  1. lynkfs

    Compiler woes

    The compiler in the latest alpha causes me grief. In previous versions the following code works fine : TLayer = Class(TObject) ... end; TNetwork = class(TW3CustomControl) public Layers : array of TLayer; Layer : TLayer; ... end; Layer := TLayer.Create; Layers.Add(Layer); In the current alpha this compiles fine too, but gives execution errors. After lots of sighs I got it to work again by changing the second to last line to Layer := new TLayer; don't understand why Another strange thing : 'ShowMessage' i
  2. I want to use next code: TYPE (* A class example. *) TClassOne = CLASS (TObject) PUBLIC PROCEDURE Stuff; END; (* Another class example. *) TClassTwo = CLASS (TObject) PUBLIC PROCEDURE MoreStuff; END; When compiling (command line smsc.exe, I didn't try on IDE) it returns next error: [ERROR] Compilation failed! Error(s): 1 Syntax Error: Unknown name "TClassTwo" [line: 68, column: 5] If I put a "TYPE" just before the second class definition, it compiles without error. That's not good.
  3. Hello! I am very new to SMS and I find it's potential very appealing, and even better that I can develop something modern in Pascal. However my first impressions of it has not been very positive because of several reasons, I will address the first reason here. When I save a project it saves just fine, but when I re-open the project I get the following error: Unknown name: TApplication and the unit called "Unit1.pas" does not seem to be saved witth the project. "Unit1.pas" is not available in the Project Manager tree on the left side of the screen upon re-open. Why is this
  4. Every time I tried to start a new project I would get a "Shortcut already exists" Error I re-booted the laptop and restarted SMS. Then I tried to open another project and that worked but when I try to create a new project it caused the error again.(I have some screen shots if required) ** It's no longer a problem because I upgraded to the latest Beta version and everything works again. Exception: ----------------------------------------------------- 2.1 Date : Tue, 27 Oct 2015 23:59:31 -0300 2.2 Address : 00A8C70B 2.3 Module Name : SmartMS.exe -
  5. I am getting an error when starting Smart Mobile Studio Professional (see attached screenshots). I purchased license in December 2014, and upgraded from Windows 8.1 to Windows 10 three weeks ago and have been using it without any problem. Kindly assist.
×
×
  • Create New...