Jump to content

Can't control names contain an underscore "_" ?


Recommended Posts

Hi,

 

I have just started with Smart Mobile Studio (downloaded the latest version 2.1.2.3592 and recreated the MyFirstProgram example from the book.

 

While it works, I have found that I apparently can't rename the controls the way I am used to with Delphi. E.g. there is the "Add"-button called "W3Button1". I would like it to be called "b_Add". It's possible to change the Name property in the Property inspector, but once I click on a different control and then on that button again, it's called "W3Button1" again. I tried a different name "btnAdd" which works.

 

Does that mean an underscore "_" is not allowed in the control names? And if so, why does the renaming operation quietly fail rather than showing me an error message?

 

twm

 

Link to post
Share on other sites

This is a bug and it has already been fixed a while ago. However, this issue was not marked as critical and thus will only be fixed in the next release. The last (hotfix) release was only targeting compiler and RTL issues where-as this was filed under 'IDE'. In fact it's only the IDE, which is limiting here, so if you hack the .pas/.sfm file it would work.

 

Since the next version is already scheduled for November (internally), there won't be another hotfix, which solves this issue in particular.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...