Jump to content
Sign in to follow this  
IgorSavkic

Designer not working

Recommended Posts

I don't know what happened designer (for any project) stopped working, doesn't show any components. Also shows empty Welcome screen. But otherwise works, projects compiles and works.

I don't know if I changed some setting that controls this.

SMS is 3.9.1.167

 

Capture.JPG

Share this post


Link to post
Share on other sites
On 2/22/2020 at 3:07 AM, IgorSavkic said:

Yes, also updating SMS, I haven't tried full reinstall.

This is weird. It has worked earlier on your computer, right?

Share this post


Link to post
Share on other sites
4 hours ago, IgorSavkic said:

Yes, it worked fine and then stopped.

My best guess is that your firewall is preventing connections from the embedded Chromium to the IDE's server component. The IDE is listening on connections to port 8090 (unless you changed that in IDE Settings/Server/Port).

If my guess is right, executing a project in the internal browser should not currently work either.

I'd first try disabling the firewall completely and see if it helps. If it does, you can review your firewall rules and remove the rule that caused it. With the normal Windows firewall, the app rules are in "Allowed apps" and you can for example delete all the rules related to Smart Mobile Studio. Once you start SMS again, the firewall should ask again if you allow the connection.

Another possibility is that a virus scanner has done a false positive and blocks some file that the embedded Chrome needs.

Share this post


Link to post
Share on other sites
On 2/27/2020 at 5:27 PM, IgorSavkic said:

That solved it, wasn't firewal but it was changed port to 8091 (IDE Settings/Server), after restart IDE stopped working. I've tried other ports and none worked. Probably 8090 is hardcoded and changing doesn't reflect that.

You're right. It was hard coded. Fix will be in the next update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×