Jump to content

Align Issue in latest Alpha Version -

Recommended Posts

I just downloaded this version and opened a project that was using various Align features. The project when run was not displaying items as I expected. So I tried something simple.

1) Created a new project

2) On the form placed a TW3Panel and aligned it with the Top (alTop) Changed the color to red just to visual see this panel at runtime ---- This works....

3) Placed a TW3Label inside the TW3Panel and selected align left (alLeft). When I run the project, the label is not visible.

4) If the change the label to align none (alNone), it displays in the panel just fine as expected.

5) If I place more controls in the panel like a button and set aligns to alLeft or alRight, strange things are happening.

If you need the project let me know, but I hope it is easy enough for you to create a project from scratch.  When I updated the Alpha version, it looked like the updater ran OK, but I can try other things if you think it is something with my update vs. the framework.


Link to post
Share on other sites
  • Administrators

@Tim Koscielski Thank you. I can reproduce the problem. Resizing the form will do, which means that something goes wrong during the initial resize right after the form has been created. Gonna have a look.

Edit: Can you try removing this from line 4595 in SmartCL.Components.pas and see if it fixes the problem?

RemoveFromComponentState([csAligning]); //Remove this line


Link to post
Share on other sites

Yes, if I make the change and comment out that line, the items do align correctly on the initial form create.

And if I leave that line enabled, you are correct that when I resize the window, they do draw correctly.

Now that you know where the issue is, I feel great that you'll come up with a solution to accommodate. The progress you have made recently with this stuff is great and I have been enjoying working with this .

And to be honest, I am using the Alpha track for production development and I had just gotten used to not leaving a way to revert back to the prior version. This time it got me. <grin>

Thanks for all you do.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...